// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\n]+\n(ААА)(\r?\n[^\n]+){2}").unwrap();
let string = "111
222
333
ААА
444
555
666";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}