$re = '/[^\n]+\n(ААА)(\r?\n[^\n]+){2}/m';
$str = '111
222
333
ААА
444
555
666';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;