#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*[}{,.^?~=+\-_\/*\-+.\|])(?=.*[a-zA-Z])(?=.*[0-9]).{8,}"
Local $sString = "12345678" & @CRLF & _
"ASDAS^^?" & @CRLF & _
"ASD1ASDA" & @CRLF & _
"WWEA^^1" & @CRLF & _
"A1234567" & @CRLF & _
"123^8542" & @CRLF & _
"A{123456" & @CRLF & _
"A^^BCVSD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")