import re
regex = re.compile(r"(?=.*[}{,.^?~=+\-_\/*\-+.\|])(?=.*[a-zA-Z])(?=.*[0-9]).{8,}", flags=re.MULTILINE)
test_str = ("12345678\n"
"ASDAS^^?\n"
"ASD1ASDA\n"
"WWEA^^1\n"
"A1234567\n"
"123^8542\n"
"A{123456\n"
"A^^BCVSD")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")