re = /(?=.*[}{,.^?~=+\-_\/*\-+.\|])(?=.*[a-zA-Z])(?=.*[0-9]).{8,}/m
str = '12345678
ASDAS^^?
ASD1ASDA
WWEA^^1
A1234567
123^8542
A{123456
A^^BCVSD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end