const regex = /(?=.*[}{,.^?~=+\-_\/*\-+.\|])(?=.*[a-zA-Z])(?=.*[0-9]).{8,}/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*[}{,.^?~=+\\-_\\\/*\\-+.\\|])(?=.*[a-zA-Z])(?=.*[0-9]).{8,}', 'mg')
const str = `12345678
ASDAS^^?
ASD1ASDA
WWEA^^1
A1234567
123^8542
A{123456
A^^BCVSD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}