using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bAPV\b";
string input = @"""APV"", ""SAPV, APV"", ""SCA, FFMM, APV"", ""SCA, SAPV"", ""FFMM, APV"", ""FFMM"", ""SCA, SAPV, APV"", ""SCA, SAPV, FFMM, FFAC"", ""SCA, FFMM"", ""SAPV"", ""SCA"", ""SCA, APV"", ""SAPV, FFMM"", ""SCA, SAPV, FFMM, APV"", ""SAPV, FFMM, APV""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}