import re
regex = re.compile(r"\bAPV\b")
test_str = "\"APV\", \"SAPV, APV\", \"SCA, FFMM, APV\", \"SCA, SAPV\", \"FFMM, APV\", \"FFMM\", \"SCA, SAPV, APV\", \"SCA, SAPV, FFMM, FFAC\", \"SCA, FFMM\", \"SAPV\", \"SCA\", \"SCA, APV\", \"SAPV, FFMM\", \"SCA, SAPV, FFMM, APV\", \"SAPV, FFMM, APV\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")