// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bAPV\b").unwrap();
let string = "\"APV\", \"SAPV, APV\", \"SCA, FFMM, APV\", \"SCA, SAPV\", \"FFMM, APV\", \"FFMM\", \"SCA, SAPV, APV\", \"SCA, SAPV, FFMM, FFAC\", \"SCA, FFMM\", \"SAPV\", \"SCA\", \"SCA, APV\", \"SAPV, FFMM\", \"SCA, SAPV, FFMM, APV\", \"SAPV, FFMM, APV\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}