package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bAPV\b`)
var str = `"APV", "SAPV, APV", "SCA, FFMM, APV", "SCA, SAPV", "FFMM, APV", "FFMM", "SCA, SAPV, APV", "SCA, SAPV, FFMM, FFAC", "SCA, FFMM", "SAPV", "SCA", "SCA, APV", "SAPV, FFMM", "SCA, SAPV, FFMM, APV", "SAPV, FFMM, APV"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}