import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<svg(?:\\s+viewBox=\"(?<viewBox>[^\"]+)\"|\\s+width=\"(?<width>[^\"]+)\"|\\s+height=\"(?<height>[^\"]+)\"|\\s+[^\"]+=\"(?:[^\"]+)\")+>";
final String string = "<svg fill-rule=\"evenodd\" fill-rule=\"evenodd\" xmlns=\"http://www.w3.org/2000/svg\" viewBox=\"0 0 100 100\" fill-rule=\"evenodd\" width=\"211\" fill-rule=\"evenodd\" height=\"61\" fill-rule=\"evenodd\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}