use strict;
my $str = '<svg fill-rule="evenodd" fill-rule="evenodd" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100" fill-rule="evenodd" width="211" fill-rule="evenodd" height="61" fill-rule="evenodd">';
my $regex = qr/<svg(?:\s+viewBox="(?<viewBox>[^"]+)"|\s+width="(?<width>[^"]+)"|\s+height="(?<height>[^"]+)"|\s+[^"]+="(?:[^"]+)")+>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}