$re = '/<svg(?:\s+viewBox="(?<viewBox>[^"]+)"|\s+width="(?<width>[^"]+)"|\s+height="(?<height>[^"]+)"|\s+[^"]+="(?:[^"]+)")+>/';
$str = '<svg fill-rule="evenodd" fill-rule="evenodd" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100" fill-rule="evenodd" width="211" fill-rule="evenodd" height="61" fill-rule="evenodd">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);