// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<svg(?:\s+viewBox="(?<viewBox>[^"]+)"|\s+width="(?<width>[^"]+)"|\s+height="(?<height>[^"]+)"|\s+[^"]+="(?:[^"]+)")+>"#).unwrap();
let string = "<svg fill-rule=\"evenodd\" fill-rule=\"evenodd\" xmlns=\"http://www.w3.org/2000/svg\" viewBox=\"0 0 100 100\" fill-rule=\"evenodd\" width=\"211\" fill-rule=\"evenodd\" height=\"61\" fill-rule=\"evenodd\">";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}