# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<svg(?:\s+viewBox=\"(?<viewBox>[^\"]+)\"|\s+width=\"(?<width>[^\"]+)\"|\s+height=\"(?<height>[^\"]+)\"|\s+[^\"]+=\"(?:[^\"]+)\")+>"
test_str = "<svg fill-rule=\"evenodd\" fill-rule=\"evenodd\" xmlns=\"http://www.w3.org/2000/svg\" viewBox=\"0 0 100 100\" fill-rule=\"evenodd\" width=\"211\" fill-rule=\"evenodd\" height=\"61\" fill-rule=\"evenodd\">"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.