using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\w+)+),?";
string substitution = @"$1\n";
string input = @"HELLO,THERE,BRUTALLY,CRUEL,WORLD";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}