use strict;
my $str = 'HELLO,THERE,BRUTALLY,CRUEL,WORLD';
my $regex = qr/((?:\w+)+),?/mp;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";