import Foundation
let pattern = #"((?:\w+)+),?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"HELLO,THERE,BRUTALLY,CRUEL,WORLD"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)