#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^name: .*(?:\n(?!name: ).*)*"
Local $sString = "name: marvin" & @CRLF & _
"attribute: one" & @CRLF & _
"day: monday" & @CRLF & _
"dayalt: test << this is a field that can sometimes show up" & @CRLF & _
"name: judy" & @CRLF & _
"attribute: two" & @CRLF & _
"day: tuesday" & @CRLF & _
"name: dot" & @CRLF & _
"attribute: three" & @CRLF & _
"day: wednesday"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")