import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^name: .*(?:\\n(?!name: ).*)*";
final String string = "name: marvin\n"
+ "attribute: one\n"
+ "day: monday\n"
+ "dayalt: test << this is a field that can sometimes show up\n"
+ "name: judy\n"
+ "attribute: two\n"
+ "day: tuesday\n"
+ "name: dot\n"
+ "attribute: three\n"
+ "day: wednesday";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}