import re
regex = re.compile(r"^name: .*(?:\n(?!name: ).*)*", flags=re.MULTILINE)
test_str = ("name: marvin\n"
"attribute: one\n"
"day: monday\n"
"dayalt: test << this is a field that can sometimes show up\n"
"name: judy\n"
"attribute: two\n"
"day: tuesday\n"
"name: dot\n"
"attribute: three\n"
"day: wednesday")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")