re = /^name: .*(?:\n(?!name: ).*)*/m
str = 'name: marvin
attribute: one
day: monday
dayalt: test << this is a field that can sometimes show up
name: judy
attribute: two
day: tuesday
name: dot
attribute: three
day: wednesday'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end