# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.0*$|(\.\d*[1-9])0+$/$1/mg;t' <<< "0
00
01
1.0
1.00
1.001100
1.101110000
1234870.98762341
1230009100
0.0012234
0.1200234
0.000001231
0.10001
NaN"