using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.0*$|(\.\d*[1-9])0+$";
string substitution = @"$1";
string input = @"0
00
01
1.0
1.00
1.001100
1.101110000
1234870.98762341
1230009100
0.0012234
0.1200234
0.000001231
0.10001
NaN";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}