const regex = /\.0*$|(\.\d*[1-9])0+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.0*$|(\\.\\d*[1-9])0+$', 'mg')
const str = `0
00
01
1.0
1.00
1.001100
1.101110000
1234870.98762341
1230009100
0.0012234
0.1200234
0.000001231
0.10001
NaN`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);