import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.0*$|(\\.\\d*[1-9])0+$";
final String string = "0\n"
+ "00\n"
+ "01\n"
+ "1.0\n"
+ "1.00\n"
+ "1.001100\n"
+ "1.101110000\n\n"
+ "1234870.98762341\n"
+ "1230009100\n"
+ "0.0012234\n"
+ "0.1200234\n"
+ "0.000001231\n"
+ "0.10001\n"
+ "NaN";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}