#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)somato(?:somatic|visceral)|viscero(?:somatic|visceral)"
Local $sString = "Whenever you have a musculoskeletal injury, there's a high chance for a somatosomatic or somatovisceral reflex. The opposite is also true, i.e. when you are having a heart attack it's very likely that you'll get nauseated (viscerovisceral) or you'll experience pain in your shoulder or jaw (viscerosomatic)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")