package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)somato(?:somatic|visceral)|viscero(?:somatic|visceral)`)
var str = `Whenever you have a musculoskeletal injury, there's a high chance for a somatosomatic or somatovisceral reflex. The opposite is also true, i.e. when you are having a heart attack it's very likely that you'll get nauseated (viscerovisceral) or you'll experience pain in your shoulder or jaw (viscerosomatic).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}