import Foundation
let pattern = #"somato(?:somatic|visceral)|viscero(?:somatic|visceral)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Whenever you have a musculoskeletal injury, there's a high chance for a somatosomatic or somatovisceral reflex. The opposite is also true, i.e. when you are having a heart attack it's very likely that you'll get nauseated (viscerovisceral) or you'll experience pain in your shoulder or jaw (viscerosomatic)."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)