use strict;
my $str = 'Whenever you have a musculoskeletal injury, there\'s a high chance for a somatosomatic or somatovisceral reflex. The opposite is also true, i.e. when you are having a heart attack it\'s very likely that you\'ll get nauseated (viscerovisceral) or you\'ll experience pain in your shoulder or jaw (viscerosomatic).';
my $regex = qr/somato(?:somatic|visceral)|viscero(?:somatic|visceral)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}