$re = '/somato(?:somatic|visceral)|viscero(?:somatic|visceral)/m';
$str = 'Whenever you have a musculoskeletal injury, there\'s a high chance for a somatosomatic or somatovisceral reflex. The opposite is also true, i.e. when you are having a heart attack it\'s very likely that you\'ll get nauseated (viscerovisceral) or you\'ll experience pain in your shoulder or jaw (viscerosomatic).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);