import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ❯ (.*)\\:(\\d+)\\:(\\d+)";
final String string = " ❯ src/textutils.test.ts:8:28\n"
+ " 6| [\"all lower case words\", \"All Lower Case Words\"],\n"
+ " 7| ])(\"startCase\", (input: string, expected: string) => {\n"
+ " 8| expect(startCase(input)).toEqual(expected)\n"
+ " | ^\n"
+ " 9| })\n"
+ " 10|\n\n"
+ " - Expected \"Baised 1/2 Chicken\"\n"
+ " + Received \"Braised 1/2 Chicken\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}