import Foundation
let pattern = #" ❯ (.*)\:(\d+)\:(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
❯ src/textutils.test.ts:8:28
6| ["all lower case words", "All Lower Case Words"],
7| ])("startCase", (input: string, expected: string) => {
8| expect(startCase(input)).toEqual(expected)
| ^
9| })
10|
- Expected "Baised 1/2 Chicken"
+ Received "Braised 1/2 Chicken"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}