import re
regex = re.compile(r" ❯ (.*)\:(\d+)\:(\d+)")
test_str = (" ❯ src/textutils.test.ts:8:28\n"
" 6| [\"all lower case words\", \"All Lower Case Words\"],\n"
" 7| ])(\"startCase\", (input: string, expected: string) => {\n"
" 8| expect(startCase(input)).toEqual(expected)\n"
" | ^\n"
" 9| })\n"
" 10|\n\n"
" - Expected \"Baised 1/2 Chicken\"\n"
" + Received \"Braised 1/2 Chicken\"")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")