// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r" ❯ (.*)\:(\d+)\:(\d+)").unwrap();
let string = " ❯ src/textutils.test.ts:8:28
6| [\"all lower case words\", \"All Lower Case Words\"],
7| ])(\"startCase\", (input: string, expected: string) => {
8| expect(startCase(input)).toEqual(expected)
| ^
9| })
10|
- Expected \"Baised 1/2 Chicken\"
+ Received \"Braised 1/2 Chicken\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}