use strict;
my $str = ' ❯ src/textutils.test.ts:8:28
6| ["all lower case words", "All Lower Case Words"],
7| ])("startCase", (input: string, expected: string) => {
8| expect(startCase(input)).toEqual(expected)
| ^
9| })
10|
- Expected "Baised 1/2 Chicken"
+ Received "Braised 1/2 Chicken"';
my $regex = qr/ ❯ (.*)\:(\d+)\:(\d+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}