using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]*.)(([a-zA-Z0-9]*|.*)*\.pdf)";
string input = @"22169203 The Greatest Trade Ever by Gregory Zuckerman Excerpt.pdf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}