re = /([0-9]*.)(([a-zA-Z0-9]*|.*)*\.pdf)/
str = '22169203 The Greatest Trade Ever by Gregory Zuckerman Excerpt.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end