package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]*.)(([a-zA-Z0-9]*|.*)*\.pdf)`)
var str = `22169203 The Greatest Trade Ever by Gregory Zuckerman Excerpt.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}