$re = '/([0-9]*.)(([a-zA-Z0-9]*|.*)*\.pdf)/';
$str = '22169203 The Greatest Trade Ever by Gregory Zuckerman Excerpt.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);