// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([0-9]*.)(([a-zA-Z0-9]*|.*)*\.pdf)").unwrap();
let string = "22169203 The Greatest Trade Ever by Gregory Zuckerman Excerpt.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}