using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?=([^""]*""[^""]*"")*[^""]*$)";
string substitution = @"\n";
string input = @" disabled hide=""a1, a2, a3"" active";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}