const regex = / (?=([^"]*"[^"]*")*[^"]*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' (?=([^"]*"[^"]*")*[^"]*$)', 'g')
const str = ` disabled hide="a1, a2, a3" active`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);