use strict;
my $str = ' disabled hide="a1, a2, a3" active';
my $regex = qr/ (?=([^"]*"[^"]*")*[^"]*$)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";