re = / (?=([^"]*"[^"]*")*[^"]*$)/
str = ' disabled hide="a1, a2, a3" active'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result