#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(-|\bK?Q?k?q?)$"
Local $sString = "K" & @CRLF & _
"Q" & @CRLF & _
"k" & @CRLF & _
"q" & @CRLF & _
"KQ" & @CRLF & _
"Kk" & @CRLF & _
"Kq" & @CRLF & _
"Qk" & @CRLF & _
"Qq" & @CRLF & _
"kq" & @CRLF & _
"KQk" & @CRLF & _
"KQq" & @CRLF & _
"Kkq" & @CRLF & _
"Qkq" & @CRLF & _
"KQkq" & @CRLF & _
"-" & @CRLF & _
"" & @CRLF & _
"Not OK:" & @CRLF & _
"QK" & @CRLF & _
"kK" & @CRLF & _
"qQ" & @CRLF & _
"KQqk" & @CRLF & _
"--" & @CRLF & _
"-k" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")