// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(-|\bK?Q?k?q?)$").unwrap();
let string = "K
Q
k
q
KQ
Kk
Kq
Qk
Qq
kq
KQk
KQq
Kkq
Qkq
KQkq
-
Not OK:
QK
kK
qQ
KQqk
--
-k
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}