re = /^(-|\bK?Q?k?q?)$/m
str = 'K
Q
k
q
KQ
Kk
Kq
Qk
Qq
kq
KQk
KQq
Kkq
Qkq
KQkq
-
Not OK:
QK
kK
qQ
KQqk
--
-k
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end