package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(-|\bK?Q?k?q?)$`)
var str = `K
Q
k
q
KQ
Kk
Kq
Qk
Qq
kq
KQk
KQq
Kkq
Qkq
KQkq
-
Not OK:
QK
kK
qQ
KQqk
--
-k
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}