use strict;
my $str = 'K
Q
k
q
KQ
Kk
Kq
Qk
Qq
kq
KQk
KQq
Kkq
Qkq
KQkq
-
Not OK:
QK
kK
qQ
KQqk
--
-k
';
my $regex = qr/^(-|\bK?Q?k?q?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}